Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

MTS Summer Movie Night - posted on 13th Jun 2018 at 10:07 PM
Replies: 5 (Who?), Viewed: 2839 times.
Forum Resident
Original Poster
#1 Old 17th Jun 2017 at 7:40 PM
Default I failed to save the world.
I usually play with everything installed. Today, I have lost many EPs and SPs. (I downgraded from 1.69 to 1.67)
In this case, I'm modifing rfilong7's "Isle of Sims III" world to take some stuff out I'm not going to play with: Pets, Island Paradise, etc.

I'm going to guess that the failed here are things that I missed deleting.

Is there a way to identify what these file numbers are? So I can delete them?
Mad Poster
#2 Old 17th Jun 2017 at 11:55 PM
No! You were the destined one!

Look out for BRIDGEPORT'88 - it's the hottest new show on YT this season!
Already renewed for '89!

(Oh, and follow me on my Tumblr.)
dodgy builder
#3 Old 18th Jun 2017 at 8:03 AM
I have no clue really, but have you tried the file with s3pe?
Forum Resident
Original Poster
#4 Old 18th Jun 2017 at 7:46 PM
Originally Posted by Volvenom
I have no clue really, but have you tried the file with s3pe?

Yes. I cloned the world the usual way: Use CAW to make a TEMP world, use S3PE to load the Temp.world, use S3PE to import resources from the .world file I want to clone, then delete the WPID and that 0x29blahblah type file, save the .world from S3PE then reload the Temp.world back into CAW and start making edits. (including a name change)

Usually it can't save the stuff that you don't have the EP/SP for, but it still saves the world. After that, the missing EP/SP stuff is gone but the world works fine after that.

Not lately. I failed to save the world.
dodgy builder
#5 Old 18th Jun 2017 at 9:01 PM
I was just thinking you could seach in the original world file for the numbers in your error message? Again I have no clue, just trowing in my 2 cent. Then you could possibly save it all over as new file and try again? My theory is that the same object keeps the same number, might not work, but ...
Lab Assistant
#6 Old 19th Jun 2017 at 9:07 PM
The only time I got these kind of errors (3/4 years ago) I went mad (working days on a city saved several times and seen my PC worked as server and was 24/7 online and a quite stable system with almost never any mistakes, so I could keep CAW active while I went away to continue later). So I saved and CAW crashed with a "item number error" after at least 30 hours creating

After that I went testing right away; the error was new and came form items/objects BUT nobody with only Sims3 with original EP/SP had the issue. The problem had to be in the downloaded expansions (scripts, objects, houses and so on)

Took some time and thought about what changed before getting the error (kept showing every time I tried to save a world) = I Deleted all downloaded expansions (4 example from the download section of this site) from the game and tested again: No error... Saving the world (and my personal Sims3 Universe for that matter

The error came from objects I took from a site from where I downloaded many times before without any problems but still in CAW it blocked all saving (even without ever using the objects, installing was enough)

I went installing in parts and after every part I tested in CAW until the errors came back = in the last installed batch was the error. Deinstalled that part and kept splitting until 1 set of items ended up to be the problem... After installing and deinstalling as confirming test I knew enough and totally deleted the set... Never had the problem again...

The numbers triggered this memory; some of the numbers seem to be connected and ended up to be: A set of windows, a set of doors, roof decoration, Other numbers without direct match were a pillar, a arche and a fence...

It will cost some time but it was worth the test for me...
1. Deinstall ALL downloaded content
2. Place object and mod files in a backup map (cut and paste, NO COPY-> most mods don't need installing by Sims3)
3. Test if problem is resolved
-No = not the same problem
-Yes = Step 4 (this is your problem and you CAN fix it)
4. Install objects with Sims3 in parts (were around 300 files for me and I made batches of 50, to keep overview: make a Map for every batch = you know EXACTLY which files you tested in every -seperate- batch) AND test saving in CAW AFTER running Sims3
4a. Install (the next) 50 objects
4b. Run Sims3 (can close without opening a world)
4c. Test saving in CAW
4d. Continue 4a/4c until all files (sims3packs) are installed
5. Still able to save? Continue with mod files in the same way as step 4 by "re"placing them in the Mods map

If the saving test fails (and you get an error as above you know that the corrupt files are in your last batch->

6. Split the batch up (I went from 50 to 10 files) and keep doing that until you find the exact files.

IF you find the corrupt files (keep sets together while batch installing, will make this easier) you can upsize the resisting batches (I went from 50 to 100), But after a couple of batches you know what it is to keep waiting for everything to load and install... At least do it in several batches; if you are fed up with it I only want to remind you before: if only 1 file of the rest is corrupt it could start all over again...

When I found the files i remembered downloading them around the start of the problem (I downloaded them for a themed world and then started building the world I got them for... As said after completing placing all height differences as wanted, all roads placed, all lots placed including correct type and name/beauty settings, decorating CAW objects and I wanted to get started building lots and I found the error = Since then I test after installing new objects, even if I download the for Sims3 and without intention using CAW for the short future, I still install, run Sims3 and when the game is loaded I start CAW (Sims3 still running on the background) and test saving a new blank world, close CAW & switch back to Sims3 to play. I understand my situation wasn't normal (and maybe still isn't because of high grade hardware), not saving for days (and by doing so taking the risk it gets lost) I don't do either anymore after this...

I know it's a complete Epos I wrote here but these kind of expierences (with all nuances) can help other sims lovers, I hope I helped you and if not at least another by the lessons from my mistakes
Back to top